QB POS: Mandatory POS v18 Security Update

Intuit is pushing out notifications in QuickBooks Point of Sale Desktop v18.0 regarding the mandatory security update (TLS 1.2)  required to continue processing credit cards through Intuit Merchant Services.

Customers using QuickBooks Point of Sale Desktop version 18.0 will receive the following in-application message:

"A new security update is available for QuickBooks POS 18.0.  Update now to ensure uninterrupted access to your POS Payments Service.  Click here to learn more."

This mandatory security update needs to be installed on all workstations that use QuickBooks Point of Sale Desktop v18.0.

Please note that this mandatory security update from Intuit (TLS 1.2) is for credit card processing through Intuit Merchant Services.  However, if you are using another integrated credit card processor with QuickBooks Point of Sale Desktop version 18.0, Intuit still recommends that this update be installed on all workstations running the application.

When you click on the link in the in-application message, it will take you to a knowledge base article on Intuit's website with information about the security update, what is required, and installation instructions.  Please read the instructions completely before beginning the installation process.  

Here is a link to download and install the security update.

You will want to make sure that QuickBooks Point of Sale Desktop v18.0 is closed before this mandatory security update is installed.

Intuit highly encourages customers using QuickBooks Point of Sale Desktop v18.0 to install this mandatory security update ASAP to prevent any disruptions with processing credit cards through Intuit Merchant Services.

---

Have more questions? Submit a request

0 Comments

Article is closed for comments.
Powered by Zendesk